Announcement

Collapse
No announcement yet.

There is a problem with this website's security certificate.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • There is a problem with this website's security certificate.

    When I'm on my laptop, that's what Norton says when I try to go to BCMB.

    It says "This organization's certificate has been revoked."

    Can someone help me figure out how to access this message board on my laptop?

    It says "Certificate Error: Navigation...

    I visited the Internet Explorer Help page, but wasn't able to connect because it says I shouldn't trust this website. It says that this often means that the security certificate was obtained or used fraudulently by the website.
    Last edited by samparnell; 05-14-2019, 10:15 AM.
    "Stultum est timere quod vitare non potes." ~ Publilius Syrus

  • #2
    Sam,

    Thanks for the feedback.

    I too have noticed some errors with the certificate though what I have seen is intermittent: sometimes an error and sometimes not. Does that describe what you are experiencing as well?

    Comment


    • #3
      Originally posted by Rastic View Post
      Sam,

      Thanks for the feedback.

      I too have noticed some errors with the certificate though what I have seen is intermittent: sometimes an error and sometimes not. Does that describe what you are experiencing as well?
      During the past week, I've seen intermittent errors on my phone, but none on the laptop until today when it just won't let me connect. I reconnected with the browser several times this morning and always got the same message.
      "Stultum est timere quod vitare non potes." ~ Publilius Syrus

      Comment


      • #4
        I have Norton too but I have not run into this problem because I never allowed it to install browser extensions. It has still stopped Web-based attacks without having those installed.

        So removing that may be an option, or using a different browser to access this forum. I have several myself and use Chrome here.

        Superbowl 50 MVP Von Miller on February 7th, 2016

        Comment


        • #5
          Originally posted by samparnell View Post
          During the past week, I've seen intermittent errors on my phone, but none on the laptop until today when it just won't let me connect. I reconnected with the browser several times this morning and always got the same message.
          That sound a little similar to my experience though I have yet not had any issue on a desktop or laptop such as you have described, only on my phone.

          I just tried two different browsers and can see the issue. We'll pass this along to the tech team.

          Thanks for your help and patience.

          Comment


          • #6
            Originally posted by L.M. View Post
            I have Norton too but I have not run into this problem because I never allowed it to install browser extensions. It has still stopped Web-based attacks without having those installed.

            So removing that may be an option, or using a different browser to access this forum. I have several myself and use Chrome here.
            I won't make any recommendations about what someone may or may not want installed. Thus far my attention is more focused on the certificate itself rather than what somebody may or may not have installed in their browser, especially since this is a fairly new issue - so I would not make any hasty decisions trying to fix something on a user's end that may likely not be part of the problem.

            Comment


            • #7
              Originally posted by Rastic View Post
              I won't make any recommendations about what someone may or may not want installed. Thus far my attention is more focused on the certificate itself rather than what somebody may or may not have installed in their browser, especially since this is a fairly new issue - so I would not make any hasty decisions trying to fix something on a user's end that may likely not be part of the problem.
              Understood. I simply offered the information that I am also a Norton user who can connect to this site without issue, and I explained why. Out of that are potential solutions for connecting -and yes, from the user end- if that's what Sam wants.

              Originally posted by samparnell View Post
              During the past week, I've seen intermittent errors on my phone, but none on the laptop until today when it just won't let me connect. I reconnected with the browser several times this morning and always got the same message.

              Superbowl 50 MVP Von Miller on February 7th, 2016

              Comment


              • #8
                Originally posted by Rastic View Post
                That sound a little similar to my experience though I have yet not had any issue on a desktop or laptop such as you have described, only on my phone.

                I just tried two different browsers and can see the issue. We'll pass this along to the tech team.

                Thanks for your help and patience.
                Can you give me the full, exact address, so that I can eliminate that possibility?
                "Stultum est timere quod vitare non potes." ~ Publilius Syrus

                Comment


                • #9
                  Originally posted by samparnell View Post
                  Can you give me the full, exact address, so that I can eliminate that possibility?
                  Sorry, Sam, I don't fully understand your question. What address is in question? The website? What is covered by the security certificate?

                  Comment


                  • #10
                    Originally posted by Rastic View Post
                    Sorry, Sam, I don't fully understand your question. What address is in question? The website? What is covered by the security certificate?
                    What should go in the https box?
                    "Stultum est timere quod vitare non potes." ~ Publilius Syrus

                    Comment


                    • #11
                      Originally posted by samparnell View Post
                      What should go in the https box?
                      You should be at https://forums.denverbroncos.com however going just to forums.denverbroncos.com should redirect to the https (secure) site.

                      Comment


                      • #12
                        Just to be clear, the site is having technical issues in part related to the security certificate. We are aware of the problem and are working to resolve the situation.

                        Comment


                        • #13
                          If I had to throw a guess out there without researching. I would suspect that the sites SSL cert, while valid, uses a cipher which is currently subpar. This was a known issue going into certain releases fo browsers and certain versions of TLS are no loner supported. Not a huge deal, but certainly annoying. I have pretty liberal browser setting based on my line of work so I haven't had the issue and cant replicate.

                          Comment


                          • #14
                            Originally posted by teetdogs View Post
                            If I had to throw a guess out there without researching. I would suspect that the sites SSL cert, while valid, uses a cipher which is currently subpar. This was a known issue going into certain releases fo browsers and certain versions of TLS are no loner supported. Not a huge deal, but certainly annoying. I have pretty liberal browser setting based on my line of work so I haven't had the issue and cant replicate.
                            This is something we are looking into, the certificate chain. Part uses (freely visible by looking at the cert) a sha-1 hash which browsers are moving away from though some still support, and of those some in a limited capacity - hence the notifications.

                            Thanks for the headsup.

                            Comment


                            • #15
                              Any noticeable changes for anybody?

                              As of this morning I am no longer see these certificate errors.

                              Comment

                              Working...
                              X